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1. Switch on

Turn on electronic control unit (using key on front; if blue light does not come on check
switch on back).switch on back).
Turn on vibration table.Turn on vibration table.
Turn on spectroscopic box.

Turn on pc; username electrochemist, password dalton.
Start EP3 software, click login; instrument will initialise. Wait until noises have stopped andStart EP3 software, click login; instrument will initialise. Wait until noises have stopped and
a Control & Live Image window has opened.

MainMain
window

Control &
Live Image

window
EP3View

Live Image

2. Sample setup and imaging2. Sample setup and imaging

Place sample on stage so that sample is under alignment laser dot (red); use a piece ofPlace sample on stage so that sample is under alignment laser dot (red); use a piece of
white paper to help if you cannot see the dot on your sample.

Transparent substrates go over the cut-out:

Close cabinet (interlocked to laser shutter).Close cabinet (interlocked to laser shutter).

PC: In the main control window EP3 View use File → Change data path to chose the folder
where you would like to save your data to, then click on select current directory.where you would like to save your data to, then click on select current directory.



PC: Control & Live Image window

Align sample – this process uses the alignment laser and camera to ensure the surface of
your sample is level.your sample is level.
Click Align; alignment window pops up and view switches to alignment camera.
If spot is visible, click auto align in pop up window.If spot is visible, click auto align in pop up window.
(If spot is not visible, drag cross-hairs in alignment window around until it is in view, then
click ‘auto align’.click ‘auto align’.
If you cannot find the spot, it may be because of your sample. You can align on somethingIf you cannot find the spot, it may be because of your sample. You can align on something
else and hope your sample is similarly level!)
Close alignment pop up window.Close alignment pop up window.

Set z height

z

Click on wavelength box to select laser incident light, thenClick on wavelength box to select laser incident light, then
open the shutter.

You can change the z position of the stage (S) or goniometer
(G). Start with the stage and use the goniometer if you need(G). Start with the stage and use the goniometer if you need
more movement. Select ZS or ZG and click on z button.
Move up or down (note that the controls are reversed withMove up or down (note that the controls are reversed with
respect to the real movement) to find the peak intensity of the

Peak intensity of laser spot; in

laser light – watch the ROI trace in the top right graph. This
should be quite bright at fairly low laser power (~5% Peak intensity of laser spot; in

this example more z
movement is required

should be quite bright at fairly low laser power (~5%
depending on sample) and moderate gain; adjust these if
necessary. If you have a transparent sample the peak movement is requirednecessary. If you have a transparent sample the peak
intensity will not be so obvious.

Repeat the alignment (see above).

ImagingImaging
Select the 550.2 bright(45) wavelength by clicking on the wavelength number, choosing it
from the list, then closing the window.from the list, then closing the window.
Rotate the polariser by clicking on the P(°) number, entering a new value (try -50°) and
closing the pop up window. Change the gain if necessary to find a bright image.closing the pop up window. Change the gain if necessary to find a bright image.
Move in x and y by clicking on the appropriate buttons to find an area of interest to image.
Click on ‘focus calibration’.Click on ‘focus calibration’.
Use the lower slider or up/down cursors whilst in the number box (the digit to the left of theUse the lower slider or up/down cursors whilst in the number box (the digit to the left of the
cursor is changed) to focus on something on your sample – a bit of dust for example.
Use the upper slider to mark the position of sharp focus in your image.Use the upper slider to mark the position of sharp focus in your image.
Close the window.
Click on the camera icon to capture an image. You can alter the resolution using the sliderClick on the camera icon to capture an image. You can alter the resolution using the slider
above it. A scan is performed so that the whole of your image will be in focus, using the
calibration that you just carried out.calibration that you just carried out.
In the EP3 View window, go to Window → Map & Image Viewer to see image. It can be
saved from here in various formats (they are not saved automatically).saved from here in various formats (they are not saved automatically).



3. Single measurement

Control & Live Image window
Chose a region of interest (ROI) by clicking on the box symbol and clicking and dragging toChose a region of interest (ROI) by clicking on the box symbol and clicking and dragging to
draw a box. For multiple ROIs, hold down shift and then click and drag.draw a box. For multiple ROIs, hold down shift and then click and drag.
In the EP3 View function tree, double click on ‘coarse adjust’ under ‘measurement’. The
instrument rotates the polariser and analyser to find an approximate position of nullinstrument rotates the polariser and analyser to find an approximate position of null
intensity.
Double click on one, two or four zone nulling. There are four positions of the polariser (P),Double click on one, two or four zone nulling. There are four positions of the polariser (P),
compensator (C) and analyser (A) that give a null value. Four zone finds them all but takes
longest.longest.
If you see an error message in red text in the main window ‘minimum not found’, you may
have to try a smaller/more homogeneous ROI, or increase the plrange and/or alrangehave to try a smaller/more homogeneous ROI, or increase the plrange and/or alrange
parameters in the function tree.

Log editorLog editor
In the EP3 View window go to Window → Log Editor. Your results appear in a table as
values of Δ and Ψ along with Angle of Incidence (AOI), wavelength, P, C, and A values.values of Δ and Ψ along with Angle of Incidence (AOI), wavelength, P, C, and A values.

4. Angle of incidence scan4. Angle of incidence scan

To collect more data you can do a one, two or four zone nulling at a range of angles. Go toTo collect more data you can do a one, two or four zone nulling at a range of angles. Go to
AOI variation in the EP3 View function tree, and chose one, two or four. Select the angle

°
AOI variation in the EP3 View function tree, and chose one, two or four. Select the angle
range and step size you wish to scan – the available range is about 38 to 80° – right-click on
the parameter to change it. Double click on one (two or four) zone to run the scan; a graphthe parameter to change it. Double click on one (two or four) zone to run the scan; a graph
window opens automatically and displays the data as it is collected. Data can be saved from
this window (this is useful to do).this window (this is useful to do).

5. Wavelength scan

Data analysis on a wavelength scan may be more complicated,Data analysis on a wavelength scan may be more complicated,
because the refractive index of the sample may vary with
wavelength.wavelength.

Go to Lamda variation in the EP3 View function tree, and choseGo to Lamda variation in the EP3 View function tree, and chose
one, two or four. Select the wavelength range you wish to scan –
these are defined by the numbers which are used in thethese are defined by the numbers which are used in the
wavelength box in the Control & Live Image window – right-click on
the parameter to change it. A step size of one will use everythe parameter to change it. A step size of one will use every
wavelength listed in the range. Double click on one (two or four)wavelength listed in the range. Double click on one (two or four)
zone to run the scan as before.



6. Other measurements

If more data is required a combined AOI/wavelength scan can be carried out. This is
accessed through the EP3 View function tree as before. The instrument can also be used toaccessed through the EP3 View function tree as before. The instrument can also be used to
measure the Brewster angle of a material, i.e. the angle of incidence at which the reflected and

°
measure the Brewster angle of a material, i.e. the angle of incidence at which the reflected and
refracted light directions are at 90° to each other.

A solid-liquid cell is available, allowing data to be collectedA solid-liquid cell is available, allowing data to be collected
from a surface under a solution.

To use this, select sl cell 60 degree in the Control and LiveTo use this, select sl cell 60 degree in the Control and Live
Image window.

The sample is aligned before adding the solution (remove the
stopper from the top of the cell). The x-y position can be foundstopper from the top of the cell). The x-y position can be found
by replacing the stopper and moving the stage so that the
alignment laser spot is in the centre of the top of the stopper.alignment laser spot is in the centre of the top of the stopper.
Focus should be around 15,000 – 16,000. The z position is
set as before. The objective is very close to the cell in thisset as before. The objective is very close to the cell in this
measurement, so take care not to make and fast stagemeasurement, so take care not to make and fast stage
movements which could cause a collision.

The cell can then be filled with the solution and the data
collection started.collection started.



7. Modelling

Ellipsometry measures Δ and Ψ, but these are not much use as they are. To obtain
information on your sample such as thickness or refractive index, you create a model ofinformation on your sample such as thickness or refractive index, you create a model of
your system which the software then fits to your data.your system which the software then fits to your data.

Open EP4ModelOpen EP4Model
Click on the ‘people’ icon to chose user and enter a session name. This is where the
software will automatically save files.software will automatically save files.

Transfer your data to EP4ModelTransfer your data to EP4Model
EP3View window, Window → Log Editor
Select data by clicking on the first cell of your data, holding down shift, then on the finalSelect data by clicking on the first cell of your data, holding down shift, then on the final
cell.
Tools → Selection → Model

If this does not work, data can be imported from EP4Model using Tools → Data from table.
Select the file that contains your data (e.g. as saved from the graph window during dataSelect the file that contains your data (e.g. as saved from the graph window during data
collection); check the column heading are correct and remove any blank rows before
importing.importing.

EP4ModelEP4Model
This contains three sections: Materials, Samples and Data & Fit.

Materials
Here you add descriptions of all the components of your sample, which may be predefinedHere you add descriptions of all the components of your sample, which may be predefined
dispersion data or functions, e.g. air for ambient or Si for substrate, or may be a substance
which is user-defined.which is user-defined.
Right-click in the space under Materials to load material for a pre-defined substance, or
create material to define your own (you can then right-click to rename it).

Samples
Here you describe your sample. Right-click → create sample. You can add extra layers ifHere you describe your sample. Right-click → create sample. You can add extra layers if
required. Right-click on each component to chose its identity from your materials list.
Thickness values can be edited by clicking on them.Thickness values can be edited by clicking on them.

Data & FitData & Fit
Here you associate data sets with samples, and add or remove parameters from the fit.
Right-click on the data set and chose bind to sample to associate it with your sample.Right-click on the data set and chose bind to sample to associate it with your sample.



Modelling procedure

You need to chose which dispersion function to use to describe your material if it has not
been loaded from the software’s database, and which parameters to fit. Materials → Right-been loaded from the software’s database, and which parameters to fit. Materials → Right-
click on material to describe → add term and chose a model (see appendix).
Data & Fit → Right-click on fit parameters to chose what to include in the fitting process. IfData & Fit → Right-click on fit parameters to chose what to include in the fitting process. If
they are not included they will be fixed at the values displayed in the Materials or Samples
tables.tables.
You can observe the effect of changing a parameter by clicking on it and using the slider.You can observe the effect of changing a parameter by clicking on it and using the slider.
Here you can also set a value and change the limits.
Click on start fit. If the process is successful, values and errors are displayed below, alongClick on start fit. If the process is successful, values and errors are displayed below, along
with a correlation table and a RMSE (route mean square error) plot (< 3 is considered
good).good).
Your session should be saved in your folder (worth checking!). You can also save a
screenshot as you go.screenshot as you go.

Example of Ni film on SiO2/Si substrate: Click here to update values
in model with the fit results

Example of Ni film on SiO2/Si substrate:
in model with the fit results

Data are shown as solid pointsData are shown as solid points

The open points and dashed lineThe open points and dashed line
represent the results of the fit

The solid line represents currentThe solid line represents current
settings of the fitted parameters



Measuring data on a blank substrate

It is possible to collect data from your substrate and use this in the modelling procedure.
This may be useful if you are doing wavelength scans, where the n and k values of theThis may be useful if you are doing wavelength scans, where the n and k values of the
substrate are not constant, and you are using a non-standard material.

Collect a data set from the substrate covering a wide wavelength range. Import the data
into EP4Model, then use Tools → Open vi. Browse tointo EP4Model, then use Tools → Open vi. Browse to
program\tools\Covert_DeltaPsi_to_effectiveSubstrate.vi and open. Click on run (arrowprogram\tools\Covert_DeltaPsi_to_effectiveSubstrate.vi and open. Click on run (arrow
icon), then select your data set and click convert now. You must save the resulting file in
C:\Program Files\Accurion\EP4Model\Dispersions (should be the default folder) in order toC:\Program Files\Accurion\EP4Model\Dispersions (should be the default folder) in order to
use it – include your initials/name in the file name to avoid overwriting any of the existing
files.files.

Measure data from your sample, and you can use your substrate file by right-clicking in theMeasure data from your sample, and you can use your substrate file by right-clicking in the
Materials section and using load material.

8. Switch off8. Switch off

Remember to copy any files you want to take away with you.Remember to copy any files you want to take away with you.
Exit software and shut down computer.
Turn off boxes in reverse order to switch on: spectroscopic box, vibration table, electronicTurn off boxes in reverse order to switch on: spectroscopic box, vibration table, electronic
control unit.
Remove sample and close cabinet doors.Remove sample and close cabinet doors.



9. Appendix

Dispersion functions

Useful reference: ‘Handbook of Ellipsometry’, H. G. Tompkins and E. A. Irene Eds., p 252Useful reference: ‘Handbook of Ellipsometry’, H. G. Tompkins and E. A. Irene Eds., p 252
(available in the library or copy in A112).

n_k_fix Fixed values of n and k, for AOI scans

eps_fix Fixed  (equivalent to above)

Cauchy For polymers, glasses, organics, etc k = 0, n = A + B/2 + C/4 + …

Cauchy_Urbach

Sellmeier Development of Cauchy function

Lorentz Original oscillator function, k > 0

Tauc_Lorentz Amorphous materials

Tauc_Lorentz_Urbach

Cody_Lorentz_Urbach

Forourhi_Bloomer Amorphous materials, k > 0

Drude Metals

Blending

EM_linear

‘Effective medium’: models the layer as a host-guest system, %guest can be fitted.‘Effective medium’: models the layer as a host-guest system, %guest can be fitted.
Assumes homogeneous distribution.

EM_Lorentz_Lorentz

EM_BruggmannEM_Bruggmann

EM_Maxwell_GarnettEM_Maxwell_Garnett

EM_linear_(3)EM_linear_(3)

Abbreviations and acronymsAbbreviations and acronyms

AOI Angle of incidenceAOI Angle of incidence
ROI Region of interest
P Polariser
C CompensatorC Compensator
A Analyser
NaN Not a number (error, probably dividing by zero)NaN Not a number (error, probably dividing by zero)



Troubleshooting

Problem SolutionProblem Solution

Light patch in image Turn off alignment lamp in function tree → Light patch in image Turn off alignment lamp in function tree → 
laser

Sample not visible,
interference seen with

Sample z-position is probably way off. Try
moving a long way in z while watching forinterference seen with

laser
moving a long way in z while watching for
collision with camera.

Data not transferring to EP4Model Save data from the graph window whenData not transferring to EP4Model Save data from the graph window when
collection has finished. This can be imported
into the modelling software (‘data from table’).into the modelling software (‘data from table’).

Captured image not in focus throughout Check the Objectives menu in the Control
and Live Image window- it should be set toand Live Image window- it should be set to
x10.

Objective incorrectly located (may be a result
of a collision with sample stage)

Can be

repositioned –of a collision with sample stage) repositioned –

ask forask for

assistance.


