
ProBe Image Data Explorer (PrIDE) 
The PrIDE software is being developed to analyse images collected using the TIS basic4 machine. It 

is specifically aimed (for the moment) at the analysis of images by ProBe (Progenitors for Beta cells 

during Pregnancy) project funded by BBSRC. However, the software can be used to analyse images 

collected for any other purpose using the TIS basic4 machine that would make it suitable for other TIS 

projects such as those at Penn State University. It is written in such a way that it is easy to add plugins 

using the UserDataPrIDE object. 

Interface 

Figure 1 shows the interface of the software. The features for each of the panels in the interface are 

detailed below. 

 

Figure 1: Interface of the PrIDE software. 1. Menu bar, 2. Toolbar, 3. Load image stack panel, 4. Enhance Visualization panel, 

5. Image display panel, 6. Select image panel, 7. Segmentation Panel, 8. Image deconvolution panel, 9. Browse panel, 10. 

Parameter file panel, 11. Histogram panel, 12. Average image intensity panel. 

1. Menu bar 

The menu bar contains three options File, Plugins and Tools 

1.1. File 

The File option in Menu bar contain options to perform general tasks. 

The first option Load −> Folder loads an image stack saved using the 

Preprocessing Software for TIS1 developed by our group for TIS 

machine. After the whole stack is loaded, the first image is displayed in 

the Image Display panel according to the settings in the Select Images 

panel. The corresponding parameter file is loaded in the Parameter File 

panel and the corresponding histogram is displayed in the Histogram panel in the software. 

                                                 

1 Preprocessing Software for TIS has been designed by our group to save all the necessary information from a TIS run in 

an organised manner. 



The next selection in the File menu is Publish which allows one 

to publish images as an html for web viewing or as a PowerPoint 

presentation, which is useful for printing and discussing the 

results during meetings. There are three different options Publish 

Z stack, ABTags and ABsets2. Selecting one of the options fixes 

the other two options and publishes all the images corresponding 

to the selection. For example, if Publish_ABTags is selected, the user is first given an option to save 

as *.html or *.ppt. The user selects the filename and the desired output format. The software then fixes 

the Z level and the Frame/set number as it is in the select images panel and publishes all the images 

corresponding to different antibody tags which fit the criteria for Z level and Frame number. 

SaveAs selection allows the user to save the image in the Image Display panel along with annotations 

in a *.png file. It also allows the user to save UserDataPrIDE object corresponding to a particular run 

which is mainly being used for debugging purposes. The feature to load the UserDataPrIDE object 

will be added in later release of the software. The final option in File menu is the Exit option which 

closes the program. 

1.2. Plugins 

Plugins menu can be opened to display currently available 

plugins in the PrIDE software. Currently, there are three plugins 

added to the software View Thumbnails, View Overlay and 

View Zstack.  

View Thumbnails work in the similar way as Publish in the File menu, i.e., selecting one of the options 

(Z level, ABTags, ABsets) fixes the other two according to select images panel and produces 

thumbnails of all the images for the selected option which fit the criteria. The difference being that 

view Thumbnails plugin produces an interactive interface which allows the user to synchronously 

analyse the images from different Z levels, Antibody tags or Frame numbers. All the interactive tools 

available for standard Matlab Figure e.g., zoom in, zoom out, pan, data cursor, print etc. are available 

with this interactive viewer.  

The next View Overlay choice allows the user to view images from different antibody tags, Z levels 

or sets by overlaying them in Red, Green and Blue channels of an RGB image. The interface shown 

in Figure 3 also allows the user to scale the intensity levels from different overlay selections to make 

the overlay better. The sliders on the right can be used to vary the intensity levels whereas the Select 

Tags button opens the Select Tags and Level control panel which allows the user to select the Tag, 

Frame/Set or Z level. This interface is particularly useful when visually analysing images from 

different antibody tags. The interface to view overlay allows standard zoom in, zoom out and pan 

functionality. The save icon allows the user to save the RGB image with selected intensity settings as 

*.png.  

View ZStack allows the user to open an interface where the user can visualize images taken from all 

the 3D sections during the TIS run. The interface for View ZStack plugin is shown in Figure 4, where 

the toolbar can be used for standard operations. On the top there is an option to select Tag, Set and Z 

level. The image corresponding to the selected settings is displayed in the left display panel and 

highlighted in pseudocolor 3D visualization on the right. The slider in the middle can also be used to 

select the Z level in the stack. 

                                                 

2 TIS basic4 allows to take the images of same visual field, Z level and antibody tag but with different settings (e.g., 

exposure times, filters etc.) To differentiate images from same visual field, Antibody tag and Z Level but with different 

settings we use Frame/set number as keyword. 



 

Figure 2: Interactive view produced by View Thumbnails which allows synchronous viewing of multiple images in the same 

window. 

 

Figure 3: View Overlay plugin to view images from multiple antibody tags by overlaying them together. 



 

Figure 4: View ZStack plugin to visualize Z levels corresponding to a particular antibody tag and setting. 

1.3. Tools 

The Tools menu is designed to perform analysis on the 

selected set of images. The results of these tools are saved 

under the PrIDEData folder as Excel sheets, mat files or 

png. The PrIDEData folder resides under the main TIS 

stack folder which contains images corresponding to the 

visual field. This one to not only save space on the hard drive but also to add/skip intermediate steps 

in an analysis pipeline. Currently there are three options under the Tools menu: 1. Register_Images, 2. 

Cell Detection, 3. Mark Ground Truth −> Cell Detection. 

Register_Images opens a new interface as shown in Figure 5 which first allows the user to select a 

good quality phase contrast image which is subsequently used as a reference image to perform 

alignment of the data [1]. The user can select a particular antibody tag with in the sequence, before or 

after incubation image, and Set number. The Current Z-level setting allows to visualize a particular Z-

level and is not used to select the reference image. Once the Register Stack button is pressed, the 

software selects setting for Antibody tag, Before/After incubation and Frame/Set No as defined by the 

user and register the images by selecting corresponding Z-levels as reference. 

By selecting the Cell Detection the software requests the user to select a DAPI image of his/her choice 

and then performs cell detection using neural networks based algorithm [2], [3]. The result of cell 

detection using the software is shown on a DAPI image in Figure 6 (a). The last option Mark Ground 

Truth −> Cell Detection allows the user to mark the ground truth for cell detection. The ground truth 

marked using this interface can be used to train machine learning based algorithms. The interface 

Figure 6 (b) allows the user to click on the nuclei to mark the ground truth and right click to delete any 

wrong markings. The user can then save his/her markings under PrIDEData folder. All the tools for 

ground truth marking for image processing algorithms will be added under Mark Ground Truth option 

in future. 



 

Figure 5: PrIDE Registration tool interface. 

 

Figure 6: (a) shows result of cell detection as red dots on a DAPI image (b) ground truth marking interface for cell detection. 

2. Toolbar 

The toolbar consists of the standard tools viewing i.e., zoom in, zoom 

out, pan, colour bar, turn on/off legend, turn on/off grid, place data 

cursor and rotate. 



3. Load Stack 

The Load Stack panel allows one to load the image stack saved using the 

Preprocessing Software for TIS. It does exactly the same job as Load −> Folder 

in the File menu. The software automatically detects the number of visual 

fields corresponding to a particular run and adds them to the drop down menu 

in the Load Stack panel. The user can select the visual field which he wants to 

analyse. 

4. Enhance Visualization 

Sometimes the intensity of the fluorescent signal is too weak to visualize using 

the original pixel intensity values. The Enhance Visualization panel allows to 

visualize the images either by ‘Normalized’ or ‘Subtracted Image’ or both. The 

Normalized option linearly stretches the histogram of the image to increase 

contrast whereas Subtracted Image option subtracts the before incubation image 

from the after incubation image and displays the result in the Image Display panel. 

5. Image Display 

The Image Display 

panel displays the 

image according to the 

settings selected in the 

Load Stack, Enhance 

Visualisation and 

Select Images panel. 

The image is displayed along with the scale on the x and y axis in µm and the title displays the image 

name currently being visualized. A right click on the display panel gives five different options. The 

first option allows the user to open the image in the default program on the operating system. The 

second option opens the folder containing the image and shows the location of the file within the folder. 

Measure allows the user to measure the length, or area of a particular region. Once the user selects 

Measure −> Length/Area, the user is allowed to mark lines/regions based on the selection and press 

Enter. The software displays the length or the area of the region in µm. The annotations can be saved 

using the save icon or can be edited or removed by doing a right click on the annotation. 

6. Select Images 

The Select Images panel allows the user to make particular selections based on the 

choice of image the user would like to view. For example, sometimes it is not 

necessary to visualize Before incubation images or phase contrast images. The user 

can uncheck the check boxes to discard them from current list for visualization and 

to quickly visualize images of choice. The Select Images panel consists of check 

boxes for before incubation, After incubation, Phase Contrast, Fluorescence, DAPI 

and Texas Red. In addition to these check boxes, the software generates drop down 

menus based on the number of antibody tags, Frame/Set numbers and Z levels. The 

Tags dropdown menu contains list of all the antibodies in the list and the user can 

select the antibody he wishes to view. The dropdown updates according to the 

antibody selection for Frame number and Z level and the user can then select Frame 

and Z number of choice. While switching between antibodies if the Frame and Z 

level with the current selection are available for the next antibody the Frame 

number and Z level are retained but the user has the choice to change them 

according to his requirements. 



7. Segmentation 

The segmentation panel allows the user to segment the current image on 

display using the method in the dropdown menu. Currently the method added 

to segmentation is Otsu’s method which allows one to segment the image 

using a thresholding mechanism [4]. In future, we plan to add more 

segmentation methods to the list in the dropdown menu. Once the image is 

segmented using the selected method, the user can Overlay the segmentation 

result on the current image selected by the Select Images panel and browse. 

The user is also allowed to click on a segmented region in the Image Display panel and display the 

average image intensity profile corresponding to all the other tags within this region in the Average 

Intensity Profile panel. 

8. Image Deconvolution 

The Image Deconvolution panel allows the user to enhance the images using 

the Lucy-Richardson deconvolution algorithm. The PSF for deconvolution is 

generated using Born and Wolf method [5]. The software to generate PSF is 

not included in the package and can be separately downloaded from 

http://bigwww.epfl.ch/algorithms/psfgenerator/.  

9. Browse 

The browse panel simply consists of two arrows forward and reverse facing to 

browse through the images. The forward facing arrow can be used to select 

next image in the list and reverse arrow selects previous image in the list 

according to criteria selected by the Select Images panel. The software also displays Aligned Image or 

Unaligned Image next to the arrows based on whether the current image has been aligned using the 

Register_Images tool. 

10. Parameter file  

The Parameter file panel displays the parameter file corresponding to the current TIS stack as shown 

in Figure 7. The parameter file contains all the necessary information about the TIS run. The panel can 

be expanded or shrunken by a right click on the panel. It also allows one to select images by clicking 

on a particular setting corresponding to a particular tag. For Example, a simple left click on the row 

33 and column 9 will open a FITC image corresponding to tag ECAD_100_C with 500ms exposure 

time in the Image Display panel. This allows the user to quickly switch from one image to another 

without using the Select Images panel. 

11. Histogram  

The Histogram panel displays the histogram of the current image on display in the Image Display panel 

as shown in Figure 1. 

12. Average Intensity Profile 

The Average Intensity Profile panel displays the average intensity of images corresponding to a 

particular tag corresponding to a particular segmented region as shown in Figure 1. The details are 

given in the Segmentation section. In future, this panel will be used for displaying analytical results 

based on our findings. 

http://bigwww.epfl.ch/algorithms/psfgenerator/


 

Figure 7: Parameter file displayed in the Parameter File panel. 

UserDataPrIDE 

The software design allows one to flexibly add plugins using UserDataPrIDE object. The properties 

and methods corresponding to the object are listed below: 

 

Property Description 

dirname Root folder for the current TIS stack. 

file_names List of all the files in the current TIS stack. 

Before_incubation Binary vector with length equal to number of images. The value sets to 1 for 

a particular file if the image was taken before incubation otherwise 0. 



Phase_image Binary vector with length equal to number of images. The value sets to 1 for 

a particular file if the image is taken with phase contrast filter otherwise 0. 

Fluor_image Binary vector with length equal to number of images. The value sets to 1 for 

a particular file if the image is taken with fluorescent filter otherwise 0. 

DAPI_image Binary vector with length equal to number of images. The value sets to 1 for 

a particular file if the image is taken with DAPI filter otherwise 0. 

TRed_image Binary vector with length equal to number of images. The value sets to 1 for 

a particular file if the image is taken with Texas Red filter otherwise 0. 

ab_list 

 
Contains the list of antibodies in the stack. 

curr_3D_sec Binary vector with length equal to number of images. Sets to 1 if the current 

image is one of the 3D slices for the current antibody. 

curr_3D Vector with length equal to number of images. Contains the current value 

for the Z level in the 3D slice. 

set_no Vector with length equal to number of images. Contains the Frame/set value 

corresponding to a particular image. 

SegH Graphical handle to the segmented object displayed on the Image Display 

panel. 

h Graphical handle to the object displayed on the Image Display panel. 

curr_list 

 
Contains the list of images selected by the Select Images panel. 

curr_id ID of current image on display. 

curr_ab ID of current antibody on display. 

curr_image Current image on display. 

curr_setno ID of current Frame/Set number on display. 

seg_functions List of Segmentation functions in the software. 

curr_zlvl ID of current Z level in the 3D section on display. 

mainaxes_cmenu Handle to context menu on Image Display panel. 

ref_ab ID of reference antibody used for registration of the stack. 

celllocations Cell locations as identified by the cell detection algorithm. 

 

Method(s) Description 

initializeud The method initializes the UserDataPrIDE object based on past selections or 

to default if the past selections are not valid. 
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