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Getting Started
User notes
This guide is based on Windows 2007/Excel 2007.  Some functions might be slightly different if you have a MAC.
There is often more than one way of undertaking an analysis using Excel and Excel can do many more analyses than are described here. Generally only one approach is provided here, but feel free to use an alternative method if you prefer.
Whichever method you use, you still need to decide which statistics should be reported and you should use an appropriate number of significant figures/decimal places when presenting results. Excel will often show a p-value of 0.000 which has been truncated to three decimal places and actually means p<0.001. A p-value can NEVER be 0.
Remember to save your work frequently!
You may well find that Excel seems very difficult at first, but, like most things in life, gets much easier with purposeful practice. Be prepared to use your problem solving skills. It is sensible to estimate what answer you expect to get from Excel as it is easy to make an error on a formula – as with calculators, don’t just take the result you get from Excel as a given!
Loading the Analysis Toolpak
Before you undertake any analysis, ensure that the ‘Analysis Toolpak’ is loaded onto your computer. This will enable you to undertake more advanced analyses.  If you are using your own computer, you only need to do this once.
Click on the Office button in the top left of the screen and select Excel options at the bottom right. Then select Add-Ins from the menu on the left and click on the Go... button next to the drop-down box at the bottom, which should say ‘Excel Add-ins’.  Click on the box next to the Analysis Toolpak and click OK.
The Toolpak can then be found in the Data menu tab.


Entering data
Excel is structured in rows (1-10,000+) and columns (A-ZZ). It is generally easiest for each observation (e.g. person) to have their own row in the database. Make sure you use suitable column headings in the first row; for example:
[image: ]
Sorting Data
You can sort the data by one or more columns, for example to list all the females and then all the males. To do this, select all of the data, including the column headings (NOT just the gender column) and click on Sort and Filter in the Home menu tab. Then select Custom Sort and the variable(s) you want to sort by.


Summary Statistics and Graphs
Drawing a histogram to determine the distributional shape of continuous data
Before you calculate any summary statistics for continuous data, you need to determine whether the data are approximately normally distributed or skewed, so you know which summary statistics to use. You will need the ‘Excel template Histogram.xls’ file which can be downloaded from Canvas.
Enter your continuous data into the green cells in column B of the template.  Select the "axis label" and "count" columns which have values in and then go to the Insert menu tab and select Scatter, Scatter with smooth lines.  Edit the graph as you see fit to make it look good (see section on editing graphs).  Assess the shape of the distribution by eye; remembering that skewness is more of a problem with small datasets.
Summary Statistics
There are many summary statistics which can be generated using Excel.  The instructions for the most common are shown in the table below – you need to decide which of these are relevant for your data. You need to put the cell reference range for which you want the statistics in brackets after the formula as (first cell reference:last cell reference), e.g. (B1:B11) for the variable ‘Age’ in the Excel sheet above. You can either do this by typing in the cell references, or you can highlight the appropriate cells by holding down the right mouse button. If you have several columns for which you want the same summary statistic, you can drag the formula across using the mouse and the column references will automatically change.
	Summary statistic
	Excel formula (reference range B1:B11 assumed)

	Number of observations
	=COUNT(B1:B11)

	Mean
	=AVERAGE(B1:B11)

	Median
	=MEDIAN(B1:B11)

	Lowest Value
	=MIN(B1:B11)

	Highest Value
	=MAX(B1:B11)

	25th percentile/Lower Quartile
	=QUARTILE(B1:B11,1)

	75th percentile/Upper Quartile
	=QUARTILE(B1:B11,3)

	Standard Deviation
	=STDEV(B1:B11)

	Standard Error
	=STDEV(B1:B11)/(COUNT(B1:B11)^0.5)

	Lower bound of 95% Confidence Interval
	=AVERAGE(B1:B11)-1.96* STDEV(B1:B11)/(COUNT(B1:B11)^0.5)

	Upper bound of 95% Confidence Interval
	=AVERAGE(B1:B11)+1.96* STDEV(B1:B11)/(COUNT(B1:B11)^0.5)

	Skewness statistic
	=SKEW(B1:B11)





Box and whisker plots
There is no simple way of constructing a box and whisker plot using Excel. You need to follow the following instructions, which can be used for one or more continuous variables:
1. Produce the following statistics for each variable you want to include on your plot:
Lower quartile (LQ)
Median - LQ
Upper Quartile (UQ) - Median
LQ error bar [LQ - Min]
UQ error bar [Max - UQ]
2. Select the column titles, LQ, Median-LQ and UQ-Median data (but not their labels).
3. Insert a 2D stacked column chart (Insert menu tab); switch the rows and columns by highlighting the graph, clicking the left mouse button, then Select Data and click on the 'Switch Row/Column' button.
4. Select the lowest part of the bar, click the Layout menu tab, Error bars, more error bars options; select a minus error bar and the 'custom' value option and click on 'specify value'.  In the box that appears, click in the negative error value box, delete the value and select the two cells corresponding to the LQ error bar from the statistics you produced in #1 and click OK.
5. Select the highest part of the bar, click the Layout menu  tab, Error bars, more error bars options; select a plus error bar and the 'custom' value option and click on 'specify value'. In the box that appears, click in the positive error value box, delete the value and select the two cells corresponding to the UQ error bar from the statistics you produced in #1 and click OK.
6. Select the lowest part of the bar, right click and select format data series and remove the fill and border (line)
7. Format the other two parts of the bar to remove the fill but add a solid line (border)
8. Label the y-axis and add a title
9. Remove the legend and gridlines





Scatter plots
You can use a scatter plot when you have two continuous variables in order to visualise the relationship between the variables. Select the data which you want to include on the plot (which must be in two columns; Excel will use the first column for the x-axis variable and the second column for the y-axis variable) and select Scatter, Scatter with only markers from the Insert menu tab. Edit the graph as you see fit to make it look good (see section on editing graphs).  In particular, you may want to change the default marker shape to an X which is generally seen as good practice for scatter diagrams; and if both axes are measured on the same scale, you should use the Format menu tab and the size option and adjust the graph size so both axes are the same length when printed.
Editing graphs
Most options can be found by selecting the graph and clicking on the Layout menu tab.
· Chart Title – should always be included, with a figure number if appropriate.
· Axes Titles – Excel calls these the horizontal (x) and vertical (y) axes.
· Axes Scales – can be adjusted by highlighting the axis and clicking the right mouse button and selecting the Format Axis option. Ensure you have a suitable scale and that the numbers have an appropriate number of decimal places.
· Legend – retain any legend if appropriate. Under the Layout menu tab you can select Legend and change the position of the legend.
· Markers/Bars – can be formatted by selecting the marker/bar on the graph, clicking the right mouse button and selecting the Format Data Series option.
· Gridlines – are a matter of personal preference, but can easily over-complicate a graph.


Statistical tests
Notes
You need to determine which test is appropriate for your data and check that any assumptions have been met. Remember to decide which statistics to report.
Chi-squared test
Download the ‘Excel template Chi squared.xls’ file from Canvas – this allows a maximum of a 10x10 contingency table.  Type in your observed frequencies (number of observations in each cell in your contingency table) into the green cells. Excel will then do the Chi-squared test for you. Scroll down the spreadsheet to find the results of the test.
Unpaired t-test
Download the ‘Excel template Unpaired t-test.xls’ file from Canvas.  Copy your data for each group into the two green columns – you do not need an equal sample size in each group. Excel will then do the unpaired t-test for you and report the results in the orange cells. Excel assumes that the assumption of equal variances is met. The p-value is the one- or two- tailed probability – use the two-tailed unless you have a good reason for not doing so.  Cohen’s d is the measure of effect size, i.e. the difference in means in terms of the number of pooled standard deviations.
Paired t-test
Download the ‘Excel template paired t-test.xls’ file from Canvas.  Copy your data for each pair into the two green columns – you must have the same number of observations in each column.  Excel will then do the paired t-test for you and report the results in the table. Again, Cohen’s d is the measure of effect size, i.e. the mean difference divided by the standard deviation of the differences.
ANOVA
You need your data in three or more columns. Go to the Data menu tab and select Data Analysis and the ANOVA: single factor option. In the dialogue box, select the data (including headings) which you want to include in your analysis (you do not need the same number of observations in each group), select that the data are grouped by columns and click on the Labels in first row box.  Click on the Output Range button and then in the box and enter the cell reference where you want the top left of your output to be. Then click OK and the results of the ANOVA will be displayed.
Mann Whitney U test (unpaired, skewed data)
Download the ‘Excel template Mann Whitney U test.xls’ file from Canvas. Copy your data into the green cells, using one column for each group (you do not need an equal number of observations in each group).  Excel will then do the test for you and report the results according to the sample size as explained in the notes on the template. You do not need to worry about the formulas provided.
Wilcoxon Signed Rank Sum test (paired, skewed data)
Download the ‘Excel template Wilcoxon signed rank sum test.xls’ file from Canvas. Copy your data into the green cells, using one row for each paired observation. Excel will then do the test for you and report the results in the orange cells.
Correlation 
The Pearson’s correlation coefficient can be found using an Excel formula: =PEARSON(array 1, array 2), where array 1/2 are the cell reference ranges for each variable e.g. =PEARSON(B1:B11,C1:C11). You can find the p-value associated with your correlation coefficient and sample size using the following web-page: http://www.danielsoper.com/statcalc/calc44.aspx
A Spearman’s correlation coefficient is slightly trickier, as you need to do the calculations yourself. Rank each value using for example =RANK(B2,$B$2:$B$200,1) and then find the difference in the ranks and square it e.g. =(D2-E2)^2. To find the correlation coefficient an example of the formula is =1-((SUM(F2:F200)*6)/(COUNT(F2:F200)^3-COUNT(F2:F200)).
Linear regression
To carry out a linear regression analysis, select the Data menu tab, the Data Analysis option and Regression.  In the dialogue box, select the data (including headings) which correspond to the y-axis (dependent variable) and x-axis (independent variable) ranges and click on the Labels box. Click on the Output Range option, click in the box and insert the cell reference where you want the top left of the results to be.  Use the Residual plot option to help you check the assumptions of the regression. Then click OK to get the regression results.

Key resource
Larry A Pace; The Excel 2007 Data & Statistics Cookbook and online templates for all statistical tests.
With thanks for permission to use.
Cookbook: http://206.192.68.20/courses/spring2008/statistics/wiki/wiki.attachments/993938.pdf
Link to templates: http://twopaces.com/stats_help.html#templates
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